×

Ошибка

[Joomlashack OSpam-a-not] Joomlashack Framework not found

2 провайдера на mikrotik с одновременной доступностью обоих интерфейсов из интернета.

Есть  2 провайдера на mikrotik, один основной второй резервный. Обычными маршрутами с разными Distance мы сделали чтоб при падении одного все изнутри ходили через второй. Но как сделать чтоб если ты заходишь снаружи например по rdp или на сам роутер через второго провайдера, при рабочем первом, все работало нормально? На входе интерфейса нужно маркировать пакеты и ответы отправлять в интерфейс с которого они пришли.

вот вкратце:

/ip firewall mangle
add action=mark-connection chain=prerouting in-interface=WAN2 new-connection-mark=From_WAN2 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=From_WAN2
new-routing-mark=to_WAN2

/ip route
add check-gateway=ping distance=1 gateway=2.2.2.1 routing-mark=to_WAN2
add check-gateway=ping comment=»ISP1 default route» distance=1 gateway=1.1.1.1
add check-gateway=ping comment=»ISP2 default route» distance=2 gateway=2.2.2.1

/ip route rule
add src-address=2.2.2.1/32 table=to_WAN2

И все работает. Далее можно пробрасывать как обычно порт на rdp или куда там еще надо.

Вот на эту тему видео с MUM :

https://youtu.be/Gwl-0bRxOY4

PS. Небольша ядобавчока к статье. Через некоторое время мне стало нужно сделать чтоб несколько компьютеров ходили в интернет через второго провайдера только.

вот как это реализовано:

1. Можно создать Address list, например назовём его WAN2_clients, в данный лист добавить нужные IP компьютеров:

/ip firewall address-list add address=192.168.88.5 list=WAN2_clients
/ip firewall address-list add address=192.168.88.6 list=WAN2_clients

2. В MANGLE прописываем правило:

/ip firewall mangle add chain=prerouting src-address-list=WAN2_clients action=mark-routing \
new-routing-mark=to_WAN2 passthrough=no

После чего все паакеты с этих айпишников маркируються и идут только через второго провайдера.

© 2018 Vesp Admins

Please publish modules in offcanvas position.